Rozwiązanie problemu z instalacją Joomli 1.5 na serwerach home.pl

Pod koniec lutego 2011 roku wielu użytkowników firmy home.pl zaczęło zgłaszać problemy z instalacją Joomli – błąd pojawiał się już na samym początku, przy próbie założenia bazy danych:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near …”.

Przyczyną okazała się być aktualizacja MySQL do wersji 5.5.8 – najnowszej stabilnej, zapewne bezpieczniejszej i szybszej, ale też wprowadzającej trochę nowych reguł, których twórcy Joomli jak na razie nie wzięli pod uwagę.

 

Osoby niezainteresowane szczegółami technicznymi, a jedynie szukające Joomli działającej na home.pl od razu odsyłam do naszego nowego działu „Do pobrania”, gdzie umieściliśmy zmodyfikowaną instalację Joomli 1.5.22 – stabilną wersję z linii 1.5.

Sama poprawiona instalacja Joomli nie rozwiązuje niestety problemów, jakie mogą występować z niektórymi komponentami i modułami – będziemy we własnym zakresie modyfikować pliki instalacyjne i umieszczać na naszej stronie.

 

Konkretnie w przypadku instalacji Joomli 1.5.22 błąd ma związek z przestarzałym zapisem TYPE=MyISAM. Wystarczy we wszystkich plikach .sql w katalogu /installation/sql/mysql pozamieniać ten zapis na obowiązujący w nowej wersji MySQL: ENGINE=MyISAM. Taka sama zmiana ‚ratuje’ też wiele komponentów i modułów.

 

Życzymy powodzenia 🙂